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THE STRING LIST EDITOR

INTRODUCTION

This chapter explains the operation of Resorcerer’s String List Editor, which
lets you create and edit resources of type ‘STR#’ and its synonyms (such as
‘mst#’).  The Editor also edits both resource template (‘TMPL’) and Type List
(‘TYP#’) resources, which are both variations of ‘STR#’ resources that
Resorcerer uses internally.  For more on resource templates, see the
“Template Editor” and “Data Editor” chapters.

String lists are used in all Mac applications to hold groups of usually related
Pascal strings.  Typically, string lists hold various small pieces of text, such
as labels, prompts, menu items, default titles, error messages, help
messages, etc., that the application presents to the user.  When you keep
your application’s strings in a ‘STR#’ resource, you can edit them with
Resorcerer without the need to recompile your program.

Resorcerer also contains filtered templates for indexed C and Pascal string
lists, which make possible both large and randomly accessible lists of
strings.  These are only editable from the template-driven Data Editor.

You should be familiar with general resource editing, as explained in the
“Editing Resources” chapter earlier in the manual.

TOPICS COVERED

•     Creating a new string list
•     Opening a string list
•     Operating the list
•     The StringList menu
•     Cutting and pasting strings
•     Decompiling the string list
•     Editing individual strings
•     Searching for text
•     Printing a string list
•     Closing the string list
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CREATING A NEW STRING LIST

If you are viewing resources in Resorcerer’s File Window, click on the New
button or choose New Resource from the File menu.  If the Types List is
the Active List, Resorcerer will ask you to specify the resource ID prior to
creating the resource; otherwise, it will use the next free resource ID
available for ‘STR#’ resources.  The resource ID at which the search begins is
specified in the Resource ID Preferences section of the Preferences
dialog (for more on this, see the “Preferences” chapter later in this manual).
Usually, the starting ID is 128.

If you are already viewing an open ‘STR#’ resource, you can choose New
Resource from the Resource menu.  The next free ID is assigned
automatically.

Once the new, empty resource has been created, the Editor opens it for
editing, so that you can add strings to it.

OPENING A STRING LIST

Select the ‘STR#’ resource you want to open in the Resources List of your
File Window, and click in the Open button.  Or double-click on the resource
entry directly.

The String List Editor
opens a dialog window
that displays the strings
in the resource, one per
line in a vertical list.
Each string is labeled
with its index into the
list, from 1 to the number
of strings in the list.
These are the indices with
which the Toolbox
routine, GetIndString ,
finds the individual
strings.

Note: Strings with carriage returns (newline characters) in them are
displayed all in one line in this window.
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SETTING THE TEXT STYLE

When you open a string list, the Editor displays the
strings in the current preferred text style.  For
standard English text strings this is usually adequate;
however, you may want to display the strings in some
other font or size.

To change the Editor’s display text style, choose Set
Text Style… from the Resource menu.  This puts up
Resorcerer’s standard text style dialog so that you can
choose from among your installed fonts how you want
the strings displayed.

To make the change only
for the current resource,
click on the dialog’s OK
button.  To install your
chosen text style as your
preferred text style for
editing ‘STR#’s, click on
the dialog’s Save & OK
button.

OPERATING THE LIST

The editing window’s GoAway box saves any changes you’ve made into
Resorcerer’s in-memory copy of your file and closes the resource.

The ZoomBox on the right side of the window’s drag bar grows the list in its
dialog window to the size of the screen on which it finds itself; or if already
zoomed, it restores the window size to what it was prior to zooming.

You can grow the list and the dialog that holds it to any size when you click
and drag the list’s grow box in the lower right corner of the list.

On either side of the list are two triangular handles.  These indicate the
position of the list insertion caret.  If no strings are selected, the caret will
also display a blinking horizontal line.  To move the caret, click on either
handle and drag it to the position you want.  If you drag it above or below
the list top or bottom, the list entries will scroll automatically.



316

RESORCERER USER MANUAL

Below the list, the New button creates a new empty string, inserts it into
the list at the position of the list insertion caret, and opens the new string
for editing.

The Edit button opens all selected strings in their own editing windows.

The Cancel button throws away all changes you may have made to the list
since you opened the resource, and closes the editing dialog.

To select a string in the list, click once on it.  The current selection tracks the
mouse if you drag it across different strings, with automatic scrolling if
necessary.  You can also find commands affecting the current selection of
strings in the Select sub-menu of Resorcerer’s Edit menu.

Changed strings in the list have a small dot displayed to the left of their
indices.  Strings currently open for editing have a larger bullet displayed to
the left of their indices.

Sorcery: cN is the keyboard equivalent of the New button.

Double-clicking on a list insertion caret handle is also equivalent
to clicking on the New button.

The list insertion caret will jump to the position you want it to be
in when you click at that position on either side of the list.

cA is the keyboard equivalent of Select All in the Edit menu’s
Select sub-menu.

Holding Shift while clicking on a string in the list extends the
current selection of strings.

Holding c while clicking on a string toggles its selection status.

The Up or Down Arrow cursor key collapses the current selection
and selects the first string above or below the former selection,
respectively.

Since the Edit button is the default button, tapping Return or
Enter will open all selected strings for editing.
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THE STRINGLIST MENU

The StringList menu is active whenever a window
created by the Editor (either a string list editing dialog
or an individual string editing dialog) is in front.  The
menu contains three commands:

New String

This command is equivalent to clicking on the New button in the list
editing dialog.  It creates a new empty string, inserts it at the current
position of the list insertion caret, and opens an editing dialog for the
new string.

Reorder Strings…

If the current
selection in the string
list contains 2 or
more adjacent
strings, you can
reorder them in the
list without cutting
and pasting when
you choose Reorder
Strings.  The index
of each selected
string is replaced
with ???? to indicate
that its position in the list is still in question.  We say its index has been
invalidated.  While reordering, a check appears next to the Reorder
Strings command in the menu.

The Editor displays an alert
reminding you of what you
need to do to reorder them,
which is to click on each
string with an invalid index
in the order you want them
to be.

When you click on a string with an invalid index, the string is cut from
the list, inserted in front of the first string with an invalid index,
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assigned a valid index, and deselected.  If there are only two strings left
to reorder, the Editor finishes the job for the last one automatically,
since it must be in its final position in the list.

Note: An invalid index is only a reminder to you that you
haven’t yet repositioned the string in your new ordering.
If you close the resource while some strings have invalid
indices, the strings are saved in the current display order.

Should you want to stop reordering prior to clicking on all the strings
with invalid indices, choose Reorder Strings again from the
StringList menu.  All strings with invalid indices are reassigned
indices corresponding to their current position in the list.

CUTTING AND PASTING STRINGS

To copy one or more strings from a string list into the Macintosh clipboard,
select them and choose Copy from the Edit menu.  The selection can be any
set of strings in the list.

To cut the selected strings from the list, choose Cut from the Edit menu.

To clear the selected strings from the list without copying them to the
clipboard, choose Clear from the Edit menu.

When copying or cutting all selected strings, they are assembled into the
same format as a ‘STR#’ resource, and placed in the clipboard as a piece of
scrap with type ‘STR#’.  They are also placed into the clipboard as plain text.
This lets you, for example, copy a string list that contains all your program’s
error messages directly into the documentation for the application.

To paste a set of strings that has been cut from a string list, place the list
insertion caret between the two strings in the list where you want the new
ones to appear, and choose Paste from the Edit menu.  The strings are
pasted, and marked as changed.  All indices of subsequent strings are
reassigned the proper numbers to reflect their strings’ new positions in the
list.
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DECOMPILING THE STRING LIST

The StringList Editor will decompile the list of strings into a Rez language
declaration.  The text is placed directly in the clipboard, so that you can
switch to your development system’s text editor and paste the declaration
into your Rez file.

To do this, first ensure that no string is currently selected in the list.  Then
choose Copy from the Edit menu to decompile the entire list to the
clipboard.

If any strings are selected, they are copied to the clipboard by themselves as
text, but not as Rez source code.

EDITING INDIVIDUAL STRINGS

To edit one or more
individual strings from a
string list, select the
strings first and then
click in the Edit button.
For each selected string,
this opens an editing
dialog in which you can
make your changes.
When a string is open for
editing, a bullet is placed
to the left of its index in
the string list.

The current length of the string is always displayed below the editing box.
Since these are Pascal strings, each string cannot be greater than 255
characters in length.  Changes you make to the string are immediately
reflected back in the string list.

To discard any changes you’ve made, click in the Cancel button.  This re-
installs the string as it was prior to opening it for editing.

When you are finished editing the string, click in the window’s GoAway box
to close it, or choose Close Resource Item from the Resource menu.
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SEARCHING FOR TEXT

For a complete explanation of how Resorcerer searches resources for text,
see the “Editing Resources” chapter earlier in the manual.

To search a string list for
a piece of text, choose
Find All… from the
Resource menu.
Resorcerer’s Find All…
dialog lets you specify the
text you want to search
for.  Once you’ve typed in
your search text, click in
the dialog’s Find button
to start the search.

The Editor searches each
string in the list for an
occurrence of the search
text.  If the string
contains a match, it is
selected in the list.  If it
doesn’t contain a match, it
is deselected.

Once the set of strings
with matches is selected,
you can open them all by
clicking in the Edit button.
Each string is displayed in its
own editing window, and the
first instance of matching text is
automatically selected so that
you can paste any replacement
text from the clipboard.
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PRINTING THE STRING LIST

To print the strings in any one string list, along with their indices into the
list, make sure the string list editing window is the front-most one, and
choose Print to Printer from the File menu.

If no strings in the list are selected, the Editor prints the entire list.
Otherwise, it only prints strings from the first selected string up to and
including the last selected string.

CLOSING THE STRING LIST

When you have finished editing a string list, click in the editing dialog’s
GoAway box to close it and save the changes you have made to the resource.
If you have made any changes, and if your Confirm resource saves
preference is set (for more on this, see the “Preferences” chapter later in the
manual), Resorcerer will ask you to confirm saving the changes.

The changes you save when closing the resource will be saved to disk when
you save or close the open file later on.
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