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EDITING FILES

EDITING FILES

INTRODUCTION

This chapter explains the operation of Resorcerer’s File Editor, which lets
you open any file in the Macintosh system for viewing or editing either its
resources or its data fork.  Later chapters document how you can create and
edit the contents of individual resources, and the operation of the individual
resource editors.

TOPICS COVERED

•     Opening an existing file
•     Opening a favorite file
•     Opening the Macintosh ROM as a file
•     Creating a new file
•     The file editing window
•     Saving and closing a file
•     Reverting an open file
•     Hiding file windows temporarily
•     Viewing and sorting types and resources
•     Comparing two resource files
•     Cutting and Pasting: The Accumulating Scrap file
•     Changing a file’s Finder information
•     Setting the Resource List text style
•     Printing a resource listing
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OPENING AN EXISTING FILE

The Open File... command in the File menu is used to open any file in the
Macintosh file system.  You are prompted to choose the file’s name and
folder using the standard Macintosh input file dialog.  Select the name of the
file you want to open, and open the file by: clicking on the Open button;
double-clicking on the file name in the list; or tapping the Return key.

Under System 7, the Open
File… dialog contains three
popup menus along the
bottom of the file/folder list.
The leftmost popup lets you
filter the list to show only
certain types of files.  The
middle popup lets you
decide whether to open an
alias file directly or whether
to open the file to which it
points.  The rightmost
popup contains the same menu as is attached to the Quick Open command
in the File menu, that is, your favorite file list.

FILE FILTERING

The file filtering popup menu lets you choose the
types of files to view.  You can choose any one of the
following settings:

Show all files
displays the names of all files and folders contained within the
current folder.  This is usually the most common setting.

Sorcery: You can reset the current filtering mode to Show all files
by typing c O from within the Open File… dialog.

Resorcerer’s only
displays only files that have been created by Resorcerer; or, if your
Change ResEdit files into Resorcerer files preference is set, this
will display ResEdit-created files as well (for more on this, see the
“Preferences” chapter).
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Resource forks only
displays only files that have a resource fork as well as a data fork.  If
the file’s resource fork has no resources in it, it will still be displayed.

Applications only
displays only application files (files with a Finder type of ‘APPL’).

“.rsrc” only
displays only files whose names end in the given suffix.  This suffix
is normally .rsrc, but you can change it to any short string you want
using the Preferences… command (for more on this, see the File
Preferences section of the “Preferences” chapter).

“.rc” scripts only
displays only text files (files of type ‘TEXT’) whose names end in the
given suffix.   These are assumed to be Resorcerer scripts, which
Resorcerer will execute rather than open for editing.  This suffix is
normally “.rc”, but you can change it to any short string you want
using the Preferences… command.

For more on scripts, see the “Running Scripts” chapter in the
Technical Stuff volume of this manual.

Sorcery: c K (for compile) is the keyboard equivalent for choosing
the scripts-only filtering mode.  In addition, you can type
c K the same way you would type c O in other parts of
Resorcerer in order to bring up the Open File… dialog
already preset to show script files only.

Suppressing folders

Regardless of which of the filtering modes you use, the display list
normally includes folder names as well as files, so that you can
traverse the Macintosh hierarchical file tree.  You can temporarily
suppress the display of any folders by holding down the Option key.
This extra folder filtering remains in effect only while you are
holding the Option key down.

Note: Certain file system navigation extensions may conflict
with this use of the Option key.  Note also that when
viewing the Desktop, volume (disk) names cannot be
suppressed using the Option key.
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RESOLVING ALIASES

Under System 7, if the middle popup at the bottom of
the Open File… dialog window is set to Resolve
aliases and you ask to open a file that is an alias file,
Resorcerer will actually open the file to which the alias refers.
However, alias files do contain resources, such as the ‘alis’ resource, or
icons.  When the popup is set to Open alias files, Resorcerer will open
the alias file directly so that you can get at them.

The system shows the names of alias files in italics in the display list.
Resolving aliases is the standard default behavior.

Note: This setting also affects alias resolution when executing a
script file in which you are including text or resources via
an alias file name.  For more on this, see the “Running
Scripts” chapter in the Technical Stuff manual.

FAVORITE FILES

The right-most popup in the Open File… dialog
contains your favorite file list.  If you don't yet
have any files in the list, the popup will show the
final entry, Set Favorite Files…, which lets you
edit the list.  For more on setting your favorite
files list, see the next section, “Opening a
Favorite File”, and the “Preferences” chapter.

When you choose a file from the popup menu, the Open File… dialog is
dismissed and Resorcerer opens the file immediately.  If the file is a
Resorcerer script, it is executed immediately.

Sorcery: c L is the keyboard shortcut for the last favorite file
you’ve opened.

OPENING THE FILE

As the file is being opened, all of the information about its resources is
read into Resorcerer’s internal storage.  However, no resource data is
read in at this time.  Resorcerer will load any resource data at the time
it is needed for whatever purpose, such as comparing, editing or copying
it.  A progress window shows you the resource types and IDs as the
information is read.



23

EDITING FILES

Once all the resource
information from the file
is read in, the resources
are sorted into separate
lists for every resource
type found.  Each list is
also sorted by ID and
checked for any duplicate IDs.  If any are found, Resorcerer lets you
know immediately.  Your File Window is then opened for editing.

Note: The Resource Manager can only determine resource sizes
by accessing the disk, which can take a lot of time.
Therefore, Resorcerer makes a best guess estimate of the
sizes during its initial file read, and then, after it has
opened and displayed the file in its window, it gets the
actual sizes from disk in the background.  You can begin
editing your file even though Resorcerer has not finished
reading in the size information.

Resorcerer edits a copy of the file’s resource information and data in
memory, and makes no changes to the actual file on the disk until you
either Close or Save the in-memory copy.

If the file’s resource fork does not exist it won’t be created until you
close the file, and then only if you have created at least one new
resource for that file while it was open.  This lets you gracefully close a
mistakenly opened file that has no resource fork and for which you don’t
want one created.

For more on how to edit a file’s data fork, see the “Data Fork Resource”
section in the “Editing Resources” chapter.

Sorcery:
c O is the keyboard equivalent of Open file… at all times.
c K sets the Open File… dialog to display script files only.
c L is the keyboard equivalent for Open last favorite file.
c N is the keyboard equivalent of the New button.
c . (period) is the Cancel button equivalent.
c Q will quit Resorcerer from within the Open File… dialog.

Note: Certain files in the Macintosh system may already be open,
particularly if you are running under System 7.  In general,
Resorcerer will not let you open a file for editing if it’s already
opened, with the exception of the System file, which is always
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open.  This means that  you can only edit a copy of your
Resorcerer application file; Resorcerer will not let you edit itself.

Note: When you open a file, Resorcerer scans the in-memory resource
map of the file to determine what resources are in it.  This direct
scan bypasses the standard Macintosh Resource Manager
routines that may operate unacceptably slowly.  In the future, it
is possible that Apple will change the internal format of file
resource maps, which may cause Resorcerer’s direct scan to work
incorrectly.  In this case, you will want to turn Resorcerer’s For
faster file opens, directly scan resource maps option off (for
more on this, see the File Preferences section of the
“Preferences” chapter later in the manual).

OPENING A FAVORITE FILE

Quite often, you may have a particular
file or files that you need to open and
close repeatedly, such as when you are
developing or testing an application.
(When using THINK C™, for example,
the project resource file must be opened,
edited, and then closed each time you
want to run your project to test the
design of a new dialog or menu or other
resource).

You can ask Resorcerer to remember the
names and positions in your file system
of any set of files that you regularly open
for editing, or scripts that you run regularly.  This lets you avoid the tedium
of having to go through the standard Open File… dialog every time.  Your
favorite files are always available in the File menu, where they appear as a
hierarchical menu belonging to the Quick Open command.  The same menu
is also always available as a popup in the Open File… dialog.

Each time you close a file represented in the Quick Open file list,
Resorcerer remembers that file’s window size and position, as well as the
state of its resource lists, so that the next time you re-open the file it can
restore your editing session.  This makes switching back and forth between
Resorcerer and your development system very easy while you are testing
your project.
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After the list of file names, the menu ends with the Set Favorite Files…
command, which invokes Resorcerer’s Preferences… command (in the Edit
menu) to let you set or edit the pathnames of your commonly opened files.
For more on how to specify your favorite files, see the “Preferences” chapter.

Sorcery: c L is the keyboard equivalent of Quick Open for the last
favorite file you’ve chosen from the hierarchical menu.  For
instance, after a test run of your application, you can switch back
to Resorcerer and simply type c L to re-open your resource file, if
it’s listed in the Quick Open menu.  c L also works from within
the usual Open File… dialog, opening the last favorite file
whereever it may be in your file system.

Sorcery: Normally, when Resorcerer re-opens a favorite file, it tries to set
the File Window back to its previous state, which includes
reselecting the last selected resource.  If you find yourself
repeatedly re-opening this resource, you can set a preference so
that it will be re-opened as well.  For more on this, see the “File
Open Preferences” section of the “Preferences” chapter.

OPENING THE MACINTOSH ROM AS A FILE

Each Macintosh machine’s Read Only Memory (ROM) contains a set of
resources in the same form as a resource file, although they are not kept in a
file that the file system knows anything about.  Most of these resources are
private Apple types; some of them, such as the standard color lookup tables,
are worth accessing or getting copies of.

If you set the Make ROM resources look like an openable file
preference in the File Preferences section of the Preferences… dialog,
Resorcerer will create a special empty file in your System folder, called
“System ROM Resources”.  Since this new file is a real file in the file system,
its name will be available in any Open File… dialog you bring up.

Whenever you ask to open this file, Resorcerer will ignore its contents and
instead read in all the resource information from the ROM.  The file is,
obviously, marked as a locked file to which no changes can be made.

You can add the “System ROM Resources” file name to your favorite files
menu if you find yourself opening the ROM frequently.

Note: The name Resorcerer uses for the ROM file is kept internally in
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one of Resorcerer’s own resources, where you can change it to
whatever you want if the default name conflicts with anything.
The default name has been designed so that it appears in the
Open File… dialog’s file list directly next to the System file.

Note: As of this writing (System 7.1), many resources in the various
Macintosh ROMs have been recorded with garbage data past
their logical ends.  You may get warnings, particularly from the
Data Editor, when you try to open these resources.

CREATING A NEW FILE

The New File command from the File menu creates an empty file in
memory with the temporary name of “Untitled”.  If more than one new file is
created, each is given a unique name such as “Untitled-2”, etc..

When you Save or Close a new file, Resorcerer
prompts you to provide a more appropriate name
before it is created and written out to disk.  Files
created by Resorcerer are identified using
Resorcerer’s document file icon, shown here:

New files have no resources in them, so the next thing you’ll want to do after
creating the new file is to create some new resources.  This is more fully
described in the next chapter, “Editing Resources”.

Resorcerer’s Open File… dialog also lets you create a new file by clicking on
the New button rather than the Open button.  A new “Untitled” File
Window is opened as if you had chosen New File from the File menu.

Note: An empty new file that has never had any new resources added to
it since it was created in memory will simply be deleted rather
than saved when you close it.  To create and save an empty file,
you must add a resource to it and then delete the resource from
the file before closing.

Sorcery: cN is the keyboard equivalent for New File, but only when no
file window is showing.  cN may have different meanings in
other contexts.
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THE FILE EDITING WINDOW

GENERAL LAYOUT

Every file you open is
represented by a File Window
that displays information about
all the resources in the given
file.  The window shows you the
various types of resources in
the file; resources of a given
type; what that resource type’s
4-character code means; and,
occasionally, other information.
In addition, buttons for your
most common editing
commands are available below the two display lists.

The File Window’s height depends on whether you have set the Use full
screen height preference (for more on this, see the “Preferences”
chapter later in the manual).  When this preference is set, Resorcerer
adjusts the height to whatever is necessary to show all the resource
types in your file, up to the height of the main screen.  If not set, it uses
the minimal window size.

In the left side of the drag bar is a standard GoAway Box, in which you
can click to close the file.  Using it is the same as choosing Close File
from the File menu.

In the right side of the drag bar is a Zoom Box, which, when clicked in,
enlarges the File Window to include a display of the file’s Finder
information (for more on what it displays, see the section “Setting the
file’s Finder information” later in this chapter).  Typically, you won’t
want to display the file’s Finder information very often, so the ZoomBox
provides a quick way to make the information easily available without
needing a separate window.  Clicking in the Zoom Box is the same as
choosing Finder Info from the File menu.

If the file is locked or otherwise can’t have changes saved to
it, you’ll be able to see a small padlock icon in the upper left
corner of the window.
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OPERATING THE FILE WINDOW LISTS

On the left side of the file window is a scrollable list of the distinct types
of all resources in the given file, called the Types List.  On the right side
is a wider list, called the Resources List, which displays all resources of
any given type.  Both the Types List and the Resources List operate
very similarly.

The Active List

At all times that the File Window is
frontmost, one or the other of these
lists is considered to be the Active
List.  The Active List is always
highlighted by drawing a bold border
around its bounds.  In the illustration
here, the Resources List is the Active
List, and it displays all resources of
type ‘STR#’ (string lists).  The Active
List is the list to which cutting, marking, or other operations apply.

To make either List the Active List, click the mouse in any part
except  the Grow box below the scroll bar.

When you are editing Finder information in the text fields of the
expanded File Window (see the “Changing a File’s Finder
Information” section later in this chapter), it is possible for neither
list to be the Active List while you are entering or editing text.

You can tap the TAB key to cycle through all active edit areas in the
window.

Growing a List

To change a list’s size, click and drag its Grow box.  The File Window
and the other list will adjust themselves appropriately.  The Types
List only grows vertically, but you can grow the Resources List in
both directions as needed.  Resorcerer adjusts the height of both lists
so that only complete list entries are displayed.

Making Selections

Clicking on any entry in the Active List deselects the previous
selection, if any, and selects the entry you’ve pointed at.
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Whichever list is active, the
Select All button selects
all entries, the Reverse
button flips the selection status of every entry in the list, and the
None button deselects all entries.

If the Types List is the Active List, the Changed button selects only
those types that have at least one resource in their list that you’ve
created or changed in any way since the file was opened or last
saved.  If the Resources List is the Active List, then the Changed
button selects only the new or changed resources of that type.

You can select all entries that are marked with a checkmark by
choosing Select…Marked from Resorcerer’s Edit menu.

Sorcery:
The Left Arrow key makes the Types List the Active List.
The Right Arrow key makes the Resources List the Active List.
The Up and Down Arrow cursor keys move the selection up and
down the Active List.

To extend the selection over a range of types, hold the SHIFT key
down while clicking and dragging.
To toggle an individual entry’s selection without affecting any
other’s, hold the c key down while clicking.

 c A is the keyboard equivalent of the Select All button.

MARKING RESOURCES AND TYPES

Both the Types and the Resources Lists allow you to place a checkmark
next to any entry.  The mark is displayed in a column at the leftmost
edge of the list.  When the mouse is placed over the check column, its
appearance changes into a checkmark to indicate that you can place a
mark there.  In general, these marks are for your use in whatever way
you want to use them to keep track of various resources while the file is
open.  They are also used by the text searching mechanism to mark
matching resources, as well as the file comparison mechanism.

When you mark a resource in the Resources List, Resorcerer also marks
that resource’s type in the Types List.  Placing a check next to any type
in the Types List causes all resources of that type to become checked,
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whether
currently
displayed in
the Resources
List or not.

To delete an
existing mark,
place the
mouse over it
and click once.
When the last
checked resource in the Resources List becomes unchecked, its type is
automatically unchecked.  When you uncheck a type in the Types List,
all resources of that type are unchecked, whether they are currently
displayed in the Resources List or not.

You can also use the Mark/Unmark command in the Edit menu to
place or erase a checkmark next to selected resource types or resources,
depending on which list is the Active List.  If any entry in the current
selection is not marked, the command will be the Mark command.  If all
entries in the selection are marked, the command changes to Unmark.

  Note: Checkmarks are not saved with the file once it’s closed.
However, they are added to any printed output.

Sorcery: c M is the same as Mark/Unmark in the Edit menu.

OPERATING THE TYPES LIST

Types are normally sorted into alphabetical order.  Those
types that have a dedicated Editor installed, and which are
considered a “major” resource (or a synonym of a major
resource) for that Editor, are shown in boldface (for more on
major and minor resources, see the next chapter, “Editing
Resources”).  Typically, these are the most common
resources you edit.  You can still edit a resource whose type
is not shown in boldface, usually with the Data Editor and a
template.  If no template is available, then the Hex Editor is always
available.

When you click on a single entry in the Types List, or move the selection
up or down using an arrow cursor key, Resorcerer automatically
displays all resources of the selected type in the Resources List.
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Double-clicking on a type will do the same, as well as make the
Resources List the Active List.

Note: You can disable the automatic fill feature, if necessary,
using the General Preferences section of the
Preferences… command in the Edit menu.

Before the Resources List is filled, all resources currently in the
Resources List are deselected before being replaced by a list of all
resources of the new type.

Selecting a Type from the Keyboard

When the Types List is the Active List, you can select any entry in it
by simply typing the characters of its 4-character type.  The search
begins with the first character you type, so you only need to use an
initial substring (e.g. typing ‘PA’ will match resource types beginning
with those letters).  The search string is accumulated anew if you’ve
not typed anything for more than about a second.

While any search string is accumulated, the TAB key searches from
the current selection with the latest search key.  If no further types
match, all types are left deselected.  Tapping the TAB key again will
reset the search to begin at the top of the list, so you can cycle
through all matching types by repeatedly tapping the TAB key.

The TAB key reverts to its normal meaning of “make the next edit
field active” after the search string timeout.

Opening a Type

The Open button, when applied to a selected type, causes the
Resources List to become the Active List and fills it with the
resources of the first selected type.  Since the Open button is the
default button, the same effect can be had by simply tapping the
Return or Enter key (when the Resources List is the Active List, the
Open button opens the resource).

Sorcery: When the Types List is active, and you have selected a
resource type by typing its 4 characters, typing a single
Space character will open the resources List for those
resources and make it the Active List.  You can then
continue typing the resource ID or name to select a
specific resource (see the next section for more on this).
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Creating a New Resource from the Types List

The New Button lets you create a new resource or set of related
resources, and is equivalent to choosing New from the Resource
menu.  However, its behavior differs slightly depending on whether
the Types List or the Resources List is the Active List.

When the Types List is active, you can specify the four-character
major type of the new resource you want to create, and, optionally,
the resource ID you want to be assigned to this new resource, as well
as its attributes or name.  Resorcerer presets the New Resource
dialog to create a resource having the first selected type in the Types
List, so you can simply click on an existing type in the Types List,
then click the button or choose the menu command.

The process of creating and opening new resources is more fully
explained in the next chapter, “Editing Resources”.

OPERATING THE RESOURCES LIST

The Resources List displays all resources
of any given type.  The standard resource
attribute bits are outined within a gray
box (blue on color systems) to the left of
the resource ID.  Above the list is a label
indicating the type of the resources
displayed, how many there are, and a
readable description of that resource
type in parentheses, if such a description
is known.

Resorcerer generally attempts to show
you the value of each resource as well as
its editing status, attributes, ID, and
name.  For example, when you open a
list of ‘ICON’ resources, it shows the
icons along with all the other
information.  Resorcerer displays the
values for most graphic resources as well
as a few non-graphic ones, such as
strings.
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For more on how Resorcerer displays particular resources, see the
“Configuring Resorcerer” chapter.  The “Viewing and sorting resources”
section in this chapter should also be of interest.

Selecting Resources by ID or Name

As with the Types List, you can select any one resource from the
keyboard by typing the characters in any part of either its resource
ID number, or its resource name (if it has one).  The characters that
you type are accumulated into a search string.  The first resource in
the list that matches the search string you’ve typed so far is selected,
and all other resources are deselected.  If you mistype something,
just wait a second or so and try again.

If the search string accumulation has not timed out, you can tap the
TAB key to get to the next resource in the list that matches your
search string.  If there are no more matches, all resources are
deselected, and the search is reset to start from the top of the list so
you can cycle through all matches by using the TAB key.

Note: The search string can match anywhere in the ID or name.
You could, for example, find every resource with the digit
7 in its ID by typing a ‘7’ and tabbing through all the
matches.  Or every one with the word “error” in its name.

Creating a New Resource from the Resources List

When the Resources List is active, and displays at least one resource
of a given type, you can quickly create a new resource or set of
related resources of the same type when you click in the New button.
Unlike when the Types List is the Active List, Resorcerer
automatically chooses for you a default resource ID and attributes
(for more on setting these defaults, see the “Preferences” chapter
later in the manual).

Opening Resources

Double-clicking on a resource causes its data to be loaded and then
opened for editing using the Editor appropriate to its type.  If there
is no Editor for its type, Resorcerer looks to see if a template
describing the resource is available and asks the Data Editor to open
it.  If no template is available, the resource can always be opened
using the general Hex Editor.
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The Open button opens every selected resource’s
data for editing using the appropriate Editor, as
if you had double-clicked on every one of them.
Since the Open button is the default button, the same effect can be
had by tapping the Return or Enter key.

As each resource in the list is opened it is marked with a  •  to
indicate that the resource is open.

The Data button is the same as the Open button, but it bypasses
any dedicated editors so that the selected resources will be opened
with their data structure templates.  If the Data button is disabled,
then no template for the currently displayed resource type is
currently available.  For more on templates, see the “‘Editing
Resources” and the “Template Editor” chapters.

The Hex button is the same as the Open button, only it forces the
general Hex Editor to be used regardless of the resource’s type.  Any
resource can be opened with the Hex Editor.

Opening Resource Information

The Info button opens a resource information dialog for every
selected resource in the list.  It is the same as choosing Resource
Info from the Resource menu, or Get Info from the Edit menu
when a File Window is frontmost.  As each resource’s information
dialog is opened, the resource is marked in the list with a  ◊  .

For more on editing resource information, such as resource IDs,
attributes, names, or types, see the “Editing resource information”
section later on in the “Editing Resources” chapter.

Sorcery: By holding the Option key down while clicking the Info
button, you can open resource information dialogs for all
resources related to the selected resource.

c I is the keyboard equivalent of the Info button when a
File Window is in front.  c I may have other meanings in
other contexts.

c R is the keyboard equivalent of Resource Info in the
Edit menu, regardless of the type of front window.
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RESOURCE INFORMATION AND EDITING STATUS

When the Resources List is filled with all resources of a given type, each
entry in the list displays information about the resource, as well as
information about its current editing state.

Initally, the list is sorted into ascending order by resource ID number.
Negative resource ID numbers, which usually represent owned system
resources (see the “Macintosh Resources” chapter for more on this
topic), are decoded to show you the owning resource type and its ID, and
the sub-ID used to identify the owned resource.  Owner information is
displayed within brackets directly next to the resource ID in the list.

  Example: The negative ID of ‘STR#’ -8185 (shown below) is decoded
to show you that the resource is owned by ‘PDEF’ 0, and
is known by this owner under the sub-ID of 7.

If a resource has an optional name, the name is usually displayed in
quotes to the right of the resource ID information.  The actual
placement depends on whether Resorcerer is able to show you the value
of the resource or not.  Generally, if the value of the resource can extend
quite far to the right (for instance, if you are viewing pattern lists
(‘PAT#’) or string (‘STR ’) resources), the resource name is drawn
underneath the resource value; if the resource value, such as an icon,
has a fixed width, the name is drawn to the right of the value.  If the
resource name is empty, no quote marks are displayed.  This lets you
tell the difference between an empty name and one that consists of
nothing but blanks, or any other invisible characters.

To the left of the resource ID column is a gray (or blue) box in which
Resorcerer displays each resource’s five standard attribute bits.  If one
of these bits is set, a small attribute icon is drawn to indicate the
attribute’s presence.  The five columns, counting from left to right, show
the resource’s sysHeap, preload, purgeable, locked, and
protected bits.  If the bit is set, an attribute icon (small Mac
for sysHeap, down arrow for preload, trash bin for
purgeable, padlock for locked, and circle with a slash
through it for protected) is displayed in its respective column.  If the bit
is clear, the resource does not have that attribute, and no icon is
displayed.
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Under System 7, certain resources can have a sixth attribute, called the
extension bit.  If any resource in a file has the extension
attribute, Resorcerer adds an extra attribute icon
column (on the right) in order to show which resources
have the extension attribute (shown as a growing set of
triangles, connoting expansion and loading).  As of this
writing (System 7.1), the extension attribute indicates that the resource
has been compressed on disk using a private Apple compression
algorithm, and that anytime this resource is asked to be delivered by
the Resource Manager, the data should be passed to a system
decompressor (a resource of type ‘dcmp’ in the System file) before being
delivered by the Resource Manager to its caller.

Directly to the left of the attributes box is a column that can contain one
of various symbols that indicate the state of the resource:

A small dot       indicates that you have changed the data, ID,
attributes, or name of the resource since you last saved the file.

An open diamond ◊  indicates that the resource attribute
information is currently open for editing.

A larger bullet  •  in the column indicates that you are currently
editing the resource data using one of Resorcerer’s editors.

Resorcerer lets you edit nearly everything using non-modal dialog
windows, so it’s possible for more than one of these indicators to be in
the column at the same time.  In these cases, they combine to form a
diamond with a dot in the middle      for a changed resource whose
attributes are open for editing; or, for a resource whose data and
attributes are both opened for editing, the bullet and open diamond
combine to form a filled diamond.

RESOURCE SIZES

Normally, Resorcerer does not display the sizes of individual resources,
in order to save space in the File Window.  However, you can choose
Show Sizes from the View menu to set all Resource Lists to show
individual resource sizes.  If the size is less than 10K, it is displayed
exactly.  Otherwise, it is displayed in boldface to the nearest K.
Resorcerer’s Preferences… dialog lets you set this display option
permanently if you want.
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SAVING AND CLOSING A FILE

When you’re done browsing or editing the resources in an
opened file, click in the File Window’s GoAway box to close
it.  Or choose Close File from the File menu.  In either
case, Resorcerer saves the file back to your disk, and
removes the File Window from the Desktop.  It is at this
time that any changes you have made to the in-memory
copy of your file are more permanently saved on disk.

The Close File command in the File menu looks at the
frontmost window to determine which file should be
closed.  If the window is a File Window, then it uses that
file.  If it is a resource editing window, it uses the file to
which that resource or set of resources belongs.  Similarly,
if it is a resource item information window, it uses the
open file in which the resource was found.

The process of closing the file is as follows.  First, all resource information
windows are closed as if you had clicked on each’s OK button or GoAway
box.  Each resource Editor that currently has any open resource(s) from the
file is asked to close any secondary windows, and then the primary editing
window, with all changes being saved to the in-memory copy of the
respective resource(s).  At this point, Resorcerer can tell whether or not the
file as a whole has had any changes made to it.  (For more on how resource
editing windows are closed, see the next chapter, “Editing Resources”.)
Depending on the options you’ve set using Preferences… in the Edit menu,
Resorcerer may confirm with you whether you want to save the changes
made to individual resources that have been opened and edited.  For more on
types of confirmation, see the “Preferences” chapter later in the manual.

Once all the windows subordinate to the File Window are closed, Resorcerer
determines if in fact the file has changed in any way.  If it has, Resorcerer
will confirm with you whether or not you want to save the changes, discard
them, or perhaps cancel the process until later.  If you do want to save them,
the file is (finally) updated on your disk, and then closed.

When you Quit Resorcerer, it will automatically assume that you want to
save and close all open files before you quit the program, and will confirm
only those files that have had changes made to them.

You can save an opened file to disk without closing it by choosing Save File
from the File menu.  If the file is new, such as an “Untitled” one or a file
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created with a script, Resorcerer will ask you to provide a more appropriate
file name before it saves the file.

You can save a copy of an opened file under a different name by choosing
Save As… from the File menu.  You’ll be prompted to provide the name of
the new file.  After the copy is created, the current open file is closed without
saving any changes to it, and you are left editing the copy you’ve just made.

Note: When Resorcerer writes resources back out to the disk, it asks the
Resource Manager to do so for each changed or new resource, in
the current sorted order.  The Resource Manager, however, does
not necessarily write these resources to disk in the same order.
For this reason, you should never depend on the order in which
resources occur within the resource fork of your file.  For more on
sorting, see the later section, “Viewing and Sorting Resources”.

If you need your resources saved in the current sorting order, use
the Save As… command to create a new copy of your file.

If there are any resource editing
windows open when you issue Save
File, and if you have the Confirm
open resources when doing a
Save File preference set,
Resorcerer will ask you how you
want to treat the open resources
prior to saving the entire file.  You
have four options: 1) close the
resources first, 2) save the open
resources in their current state (including any changes) but leave them open
for further editing, 3) ignore them and save only closed changed resources to
the file, and 4) cancel the Save File command.  The third option, ignoring
open changed resources, lets you continue editing the open resources while
keeping open the possibility of reverting them from the disk file.

Note: When you save a changed file back to disk, the file’s modification
date is reset to the current date and time.  However, this is not
done if you have explicitly edited the modification date.  In this
case the date is set to whatever you’ve set it to be.  The “Changing
a File’s Finder Information” section later in this chapter tells how
to change the modification date.

Sorcery: Option-clicking in a File Window’s GoAway box will save and
close all open files.
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REVERTING AN OPEN FILE

If you have made any changes to any part of an open file,
such as to any of its resources or its Finder information,
you can discard those changes and start anew with a fresh
copy of the file as if you’d just opened it from your disk.

Choose Revert File from the File menu.  You will be
asked to confirm that you do in fact want to discard all
changes you’ve made since the file was read from, or last
saved to, disk.  Resorcerer then reverts the entire file.
This entails canceling and closing all open resource editing
dialogs.  It then places the File Window back in the same
state as when you first opened the file.

Note: If you want to revert individual resources while leaving other
changed resources alone, you should use Revert from the
Resource menu, which is documented in the next chapter,
“Editing Resources”.

HIDING FILE WINDOWS TEMPORARILY

Resorcerer’s most important resource Editor is its Dialog
Editor, which lets you directly edit dialogs and other
resources as they normally would look when created in an
application.  If you find the presence of a Resorcerer File
Window in the background visually disruptive while you’re
editing a dialog in the foreground, you can hide the File
Window by choosing Hide File Windows from the File
menu.

Hiding the File Window is also very useful when you edit
graphic resources, such as ‘PICT’s or ‘cicn’s, since you may
want to take a snapshot of something in a desk accessory
or a different application, such as a paint program, that
resides in a background application window.

All File Windows are hidden when you use this command.  The title of the
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command in the menu changes to Show File Windows once you have
hidden any files, and choosing Show File Windows brings the hidden
windows back into view.

If you decide to Quit while any File Windows are hidden, they are
automatically reshown prior to being closed.

VIEWING AND SORTING TYPES AND RESOURCES

SORTING OPTIONS

When you first open or create a file, the Types List is
set to display resource types alphabetically, and the
Resources List numerically by ID.  You can change
the sorting criteria using the View menu.

View by ID
sorts resources in increasing order by resource ID.
This is Resorcerer’s default method.

View by Name
sorts resources alphabetically by resource name when the Resources
List is active.  Under System 7, Resorcerer compares name strings
using the Macintosh’s script utilities; otherwise, comparison is done
in ASCII only.

Sorcery: You can sort your resources by name, and then renumber
them consecutively using the Change All… command so
that their names appear alphabetically even when using
View by ID (don’t do this unless you know what you’re
doing, however).  This works for other sorting orders also.

View by Type
sorts the Types List alphabetically by type.  This is the same as the
View by Name command, but only when then Types List is active.
Sorting by type is the default method for the Types List.

View by Size
sorts resources in increasing order by size if the Resources List is the
Active List, or sorts the Types List in increasing order by types if the
Types List is Active.  When sorting types by size, Resorcerer adds up
all the individual resource sizes for each type and uses the sums.
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View by Attributes
sorts resources by attribute bits, grouping resources with the same
attributes together.

View by Data
sorts resources in “increasing” order according to the numerical
values of the data.  In general, this is not very useful, except for
resources that begin with a version word.  However, there are
certain resources that can be easily sorted by data.  In particular,
when you choose View by Data, Resorcerer sorts string (‘STR ’)
resources alphabetically.

View by File Input Order
sorts resources or types in the order they were delivered by the
Resource Manager when you opened your disk file.  This can tell you
information about how they are organized on the disk.

Note: When you save an existing file, the order in which
individual resources are eventually written can not be
counted upon.  The simple act of editing a resource near
the beginning of a file can cause the Resource Manager to
save the changed resource at the end of the file.

The View by Type/View by Name, View by Size, and View by File
Input Order commands affect the display of either the Types List or
the Resources List, depending on which is the Active List at the time
you choose the command.  This lets you sort types by size at the same
time as sorting individual resources by ID, or other combinations.

HIDING THE DISPLAY OF RESOURCE DATA

The Hide Data command in the View menu tells Resorcerer to avoid
attempting to display the data for each selected resource type if the
Types List is active, or for all resources of the type being displayed in
the Resources List if it is active.

Resorcerer uses special code resources of type ‘SHOW’ to display
resource data (for more on this, see the “Configuring Resorcerer”
chapter).  If the data for a resource, such as a large ‘PICT’ or ‘cicn’,
takes a long time to draw, scrolling a long list can become cumbersome.
More importantly, if a resource’s data is corrupted or, as happens more
often, is compressed by a third-party utility, Resorcerer may crash or
otherwise misbehave.
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The Hide Data command lets you continue working while avoiding
these problems.

Sorcery: Option-clicking on a resource type in the Types List
toggles whether the data of resources of that type are to
be displayed or not.

COMPARING TWO FILES

Sometimes you may need to see which resources are
different or unique in two versions of a resource file.  This
lets you get your bearings if you’ve been away from a
project for a while, or if you need to find which resources
have been changed since the last backup.  Resorcerer has
a simple integrated command that makes this easy to do.

To compare two resource files, open each of them and
choose Compare Two Files from the File menu.  The
command is only enabled if exactly two files are open at
the same time.

Note: The resource scrap file (described in the next
section) cannot be compared against.

Only resources with the same type and ID in each file are considered
initially comparable.  If a resource with a given type and ID appears in one
file but not the other, it is considered a unique resource.  If two resources
have different types or IDs, but have the same internal data, they will be
assumed to be different, and won’t be compared any further.

Before comparing,
Resorcerer will ask you
to specify which criteria
you want to use to
distinguish “different”
resources.  Resorcerer
then erases all
checkmarks in both files
and compares the files against each other, marking those resources it finds
with differences.
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The various criteria you can use are:

Unique resources
Look for resources in one file but not the other.

Different attributes
Among those resources sharing the same type and ID in each file, look
for differences in their attribute bits.

Different names
Among those resources sharing the same type and ID in each file, look
for differences in their resource name strings.  Upper and lower case are
considered different, as are diacritical marks.

Different data
Among those resources sharing the same type and ID in each file, look
for differences in their resource data.

Before loading resource data, Resorcerer will first compare the resource
sizes.  If the sizes are different, no data is loaded and it will assume the
data is different.  For this reason, when you have checked Different
data, the Different sizes checkbox is disabled.

When comparing resource data, there must be enough memory to load
both resources being compared.  You may need to increase Resorcerer’s
partition size when comparing resource files with large picture, sound,
or other resources in them.

Different sizes
Among those resources sharing the same type and ID in each file, look
for differences in their data sizes only.  This comparison criteria is
available only when the Different data criteria above is not checked.
Comparing by resource sizes is occasionally necessary when the two
files have resources so large that they can’t be loaded simulataneously.

Currently, Resorcerer only marks those resources found to be different.  It
cannot tell you precisely where differences occur, only that they are there.
However, you can use the Hex Editor to find individual differences between
two resources that have been marked with this command.

Note: Comparison does not extend into individual resource editing
sessions.  The data used in any resource comparison is the value
on disk if you haven’t closed the individual resource Editor yet.
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CUTTING AND PASTING:
THE ACCUMULATING SCRAP FILE

Resorcerer supports a special resource file in memory,
called the Resource Scrap, which can be thought of as
an accumulating clipboard.  This file is normally
invisible, but you can view it by choosing
Show Clipboard from the Edit menu.

The Resource Scrap is displayed in its own File
Window, initially over on the right side of your screen.
Like other File Windows, it displays both a Types List
and a Resources List, which work entirely the same as
in any other File Window.  You can display the
resources of any given type, make various kinds of
selections, etc.  Resources in this file are kept in sorted
order, and their IDs, names, and attribute bits can be edited directly just as
in other files.

Note: You cannot edit the data
of resources in the scrap
file.  You can, however,
edit the resource
information, such as ID
numbers.

Clicking in the GoAway box of the
Resource Scrap, or choosing
Close File when it is the
frontmost File Window, makes the
Resource Scrap file invisible again; it is never really closed.

BASIC OPERATION

The Resource Scrap accumulates resources as you cut or copy to it, or
when scrap from other applications or desk accessories is imported.  You
can have as many types and as many resources as you want in the
Resource Scrap (within memory limits).  Furthermore, since the Scrap
is kept in just another File Window, you can make the same kind of
selections as you would for any other file.
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This means that you can very easily cut and paste multiple resources,
as well as sets of related resources, all in one operation.

When you cut a selection of resources from a file, all the resources in the
selection are transferred to the Resource Scrap, where they are left
selected (even if the Resource Scrap File Window is not showing) after
deselecting any previous scrap selection.  This requires loading the
actual resource data from the original file, if it is not already.

When you paste from the Resource Scrap, copies of all selected
resources are transferred to the destination file.  No paste can occur if
there is no selection in the Resource Scrap, in which case Resorcerer
will show the Scrap File Window and alert you to the problem.

EXTENDING THE SELECTION TO INCLUDE RELATED RESOURCES

As the design and operation of the Macintosh system has evolved over
the years, programmers have increasingly been forced to keep
information about various system objects (such as dialogs, alerts,
menus, etc.) in more than one resource.  Typically the link between
related resources has been that they share the same resource ID,
although in the case of dialogs and alert templates the resource ID
number of the related item list (‘DITL’) resource is directly incorporated
into the resource data.  For instance, the information specifying a
particular alert might be found in four different related resources
(‘ALRT’, ‘DITL’, ‘actb’, and ‘ictb’).

Whenever you select a resource, Resorcerer will automatically include
resources that are related to the ones already selected.  The most
important example of this occurs when you select a ‘DLOG’ or ‘ALRT’
resource for cutting, copying, etc.  The associated ‘DITL’ resource and
any optional color table resources will automatically be included in the
operation as well.  In this way, you can cut and paste groups of related
resources by selecting only the most important resource of the group.

This automatic selection capability is governed by a list of groups of
related resources that is kept in Resorcerer’s own resources.  For
details, see the chapter entitled “Configuring Resorcerer”.

  Note: You can disable the automatic selection of related
resources by using the Selection Preferences section of
the Preferences… command in the Edit menu.



46

RESORCERER USER MANUAL

EXTENDING THE SELECTION TO INCLUDE OWNED RESOURCES

Certain system resources, such as desk accessories, drivers, and various
kinds of definition functions, can explicitly “own” other resources in the
same file.  The connection is implemented by forcing the owned
resources to have resource IDs that are negative and found within
certain ranges that are reserved for those resource types that can own
others (for more information on owned resources, see the “Macintosh
Resources” chapter earlier in the manual).

When you select one of these owning resources for cutting or pasting,
Resorcerer will include all of the owned resources in the operation as
well.  This lets you manipulate the entire collection of resources by
manipulating only its owner.

  Note: You can disable this feature by using the Selection
Preferences section of the Preferences… command in
the Edit menu.

OPERATING ON MARKED RESOURCES ONLY

The Cut, Copy, and Clear commands check to see what the current
Active List is to determine how to behave.  If the Active List is the
Resources List, then the current selection of resources is the target of
the operation.  If the Types List is the Active List, then all resources of
the selected types are considered candidates for the operation.

However, in the latter case, if Resorcerer notices that some of the
resources of the selected types are marked, it will ask you whether you
want to operate only on marked resources of each selected type, instead
of including them all.  This lets you cut, copy, or clear only marked
resources in one command.

CUTTING RESOURCES

When a file’s Types List is the Active List (that is, surrounded by a bold
border), choosing Cut from the Edit menu cuts all resources of all
selected types from the file.  The cut resources are incorporated into the
Resource Scrap.  Any previous selection in the Scrap is deselected and
the newly inserted resources are left selected.  The Types List of the
Scrap File becomes its Active List if it wasn't already.
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If there are both marked and unmarked resources of any given selected
type in the Types List, you are asked whether to cut only the marked
resources, or whether you want to cut all resources of the selected types.

When the Resources List is the Active List, choosing Cut from the Edit
menu will cut all selected resources from that list.  The Resources List
of the Scrap File becomes its Active List if it wasn’t already, and the cut
resources are left selected in the Resource Scrap file.  If you cut all of
the resources in the Resources List, the entry for their type is
automatically deleted from the Types List.

If any of the resources you cut are related to or own other resources in
the same file, those others also will be transferred to the Resource Scrap
if, via the Selection Preferences section of the Preferences…
command in the Edit menu, you have specified to do so.

Resources incorporated into the Resource Scrap file are inserted into its
lists according to the currently set sorting order, usually in alphabetical
order by type, and numerical order by resource ID.  Unlike other File
Windows, there are no restrictions on having multiple resources that
share the same type and ID in the Scrap.

  Note: The actual cutting of a resource from the file on disk will
not occur until you save the file later.

CLEARING OR DELETING RESOURCES

The Clear command in the Edit menu clears any selection of resources
from the file in which they’re found.  You can also simply tap the Delete
key to clear the current selection.  This is similiar to cutting them, only
they are not placed in the Scrap file; they are simply deleted.  If the
Types List is active, all resources of all selected types are cleared unless
there are some marked resources among unmarked ones, in which case
you are asked whether to clear only the marked resources, or to clear all
of them.

If the Resources List is active, then only those selected resources are
cleared.  You can just as easily clear any selection of resources from the
Resource Scrap file as from any other File Window.

If any of the resources you clear are related to or own other resources in
the same file, those others will also be cleared, if you have so specified
in the Selection Preferences section of the Preferences… command
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in the Edit menu.  For example, if you select ‘ALRT’ in the Types List
and tap the Delete key, all ‘ALRT’s will be cleared, along with all
‘DITL’s they reference, and any related optional color resources as well.

  Note: The actual clearing of a resource from the file on disk will
not occur until you save the entire file later.

PASTING RESOURCES

When you choose the Paste command from the Edit menu, Resorcerer
looks at the Resource Scrap file to see which is its Active List, and
whether or not anything has been selected in that list.  If there is no
selection in the Active List, but there are resources in the Scrap File,
Resorcerer alerts you to the fact that it is not able to determine which
resources you want to paste.  If the Resource Scrap window is invisible
at this time, Resorcerer makes it visible for you so that you can select
the resource(s) or types that you had intended to paste.  You can then
issue the Paste command again.

Since it is meaningless to paste from the Resource Scrap to itself,
Resorcerer interprets a Paste command slightly differently when the
Resource Scrap window is the frontmost window.  In this case, if there
is exactly one other File Window open, it is assumed to be the
destination of the paste, and the selected resources in the Scrap File are
pasted to that file.  If there is more than one open File Window, then
Resorcerer won’t be able to determine the destination file and it will ask
you to bring that destination File Window to the front.  You can then
reissue the Paste command.

Resorcerer will not allow you to paste a resource into the destination
File Window if a resource of the same type and ID already exists in the
file.  If such a resource exists, Resorcerer will alert you to the problem
and provide you with the option of replacing the existing resource or
resources with the ones you’re pasting, or cancelling the paste.  If you
cancel, you can change a resource’s ID while it is still in the Scrap file to
some other non-conflicting value and then try pasting again.

Note: Earlier versions of Resorcerer transferred the selection
from the Resource Scrap file, without leaving any copies
in it.  This feature, implemented back in the 1MB Mac
Plus days, helped save memory.  As of Resorcerer 1.2, the
Resource Scrap now works more like other standard
Macintosh applications, so that you can make multiple
pastes of the same resource(s) into different files.
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Sorcery: To transfer the selected resources from the Resource
Scrap file to a destination file without leaving copies in
the Resource Scrap file, choose Paste while holding the
Shift key down.

COPYING RESOURCES

The Copy command in the Edit menu copies all selected resources from
the frontmost File Window into the Resource Scrap.  If the Types List is
the Active List, all resources having the selected types from the list are
copied.  If some of them are marked, however, you are asked whether
you want to copy only the marked resources, or all of them.

If the Resources List is the Active List, only the selected resources of
that type are copied.  All selected resources in the Scrap are deselected,
and the copied resources are left selected, ready to be pasted into some
other File Window.

DUPLICATING RESOURCES

When the Resources List is the Active List, Duplicate Selection in the
Edit menu will duplicate all selected resources.  For a fuller
explanation of resource duplication, see the “Duplicating Resources”
section in the next chapter, “Editing Resources”.

IIMPORTING THE SCRAP FROM OTHER APPLICATIONS

Resorcerer imports data from the desk scrap for a variety of standard
types, including ‘TEXT’, ‘styl’, ‘snd ’, ‘PICT’, and Finder icons.  When it
does so, it automatically converts these scraps into resources by
assigning the next free ID number it can find, and gives the new
resource the name “(from Desk Scrap)”.

It is possible to extend the list of scrap types that Resorcerer will import
by editing one of Resorcerer’s own resources.  In addition, Resorcerer
will import complete resources (including attributes, IDs, names, and
data) when they are exported by other applications using a special
resource list scrap type.

For more on these topics, see the “Scrap Types” section of the
“Configuring Resorcerer” chapter later in this manual.
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CHANGING A FILE’S FINDER INFORMATION

Every file in the Macintosh file system has certain attributes that are used
by the Finder, such as its file type, creator, modification and creation times,
etc.  These attributes become directly editable when you choose Finder Info
from the File menu, or when you click the mouse in a File Window’s Zoom
Box.  In either case, the File Window is enlarged to show you various dialog
items that let you edit the file’s Finder attributes.

Below the selection
and other buttons in
the expanded File
Window, you’ll find
the file’s Type and
Creator fields.
These show you the
four-character codes
that the Finder and
other applications
use to distinguish
among different Mac
files.

The creation and modification date and times are editable.  Any changes you
make to these fields will be recorded the next time you Save the file to disk.
If you have not made any changes to the modification time, but have made
changes to some resource in the file, then when the file is written to disk a
new modification time will be assigned to it.

To the right of the Resources List are three popup
menus for various file attributes.

The first popup lets you set the file’s Finder
attribute bits.  Each entry in the menu lists the bit
number in the attribute word followed by its
meaning.  The bits listed in the popup differ
depending on whether you are currently running
under System 6 or System 7, since the Finder
attributes have different meanings.

Under System 6, the Finder flags as of this writing
are:
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Desktop The file’s icon is on the Desktop (not in its folder)
Shareable The file is a shareable application
Inited The file has been seen by the Finder
System The file is a System file
Bundle The file has a Finder ‘BNDL’ resource
Invisible The file is invisible to the user
Locked The file can’t be changed (read-only)

Under System 7, the Finder flags as of this writing are:

Shareable The file is shareable
Inited The file’s bundle has been seen by the Finder
Custom Icon The file has a custom icon
Stationery The file is a stationery pad
Locked The file name can’t be changed from Finder
Bundle The file has a Finder ‘BNDL’ resource
Invisible The file is invisible to the user
Alias The file is an alias that points to another file

The “Finder File Flags” section of the “Configuring Resorcerer” chapter
contains more info on how to add or delete entries to these popups.

The second popup lets you set the file’s resource map attributes.  Again, the
bit numbers of the attributes are displayed next to their meanings.  These
bit numbers are the same as the bits that the Toolbox’s SetResFileAttrs
takes as an argument.  The two defined attributes as of this writing are:

Resource map is Read-Only
Print driver is MultiFinder-compatible

In general, you can ignore these attributes, leaving them both off.  For more
information on Resorcerer’s resource map attribute capability, see the
“Configuring Resorcerer” chapter.

Note: The Print Driver is MultiFinder-compatible attribute is a
private Apple system software attribute.  Do not change its value
unless you know what you’re doing.

The third popup lets you choose the label/color that the Finder associates
with the file’s 1-bit icon.  The index (0-7) of the color you choose from the
popup menu is encoded into bits 2, 3, and 4 of the Finder attributes word.
This popup menu is essentially the same as the Finder’s Label menu.

In the upper right corner are the sizes of both halves of the file as it is
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recorded on disk: its resource fork and its data fork.  In the lower right
corner are certain status bits that are shown for informational purposes
only: they are not changeable.

When you’ve finished editing or looking at this information, you can tuck it
back out of sight by clicking in the Zoom Box again to reset the File Window
back to what it was.  Or you can choose File Info from the File menu.

SETTING THE RESOURCE LIST TEXT STYLE

Each open File Window has associated with it a
current text style.  When you initially open a File
Window, the current text style is copied from the
default text style, which is stored in Resorcerer’s
preferences file.  Once opened, the File Window’s
Resources List displays text associated with each
individual resource using this style.  The resource ID,
name, and usually any text in the resource data gets
drawn in the current style (this depends, however, on
the specific behavior of any associated ‘SHOW’ code
resources; for more on these, see the “Configuring
Resorcerer” chapter).

When a File Window is
frontmost, choose Set
Text Style… from the
Resource menu to
specify either the current
or the default display
text style for the
Resources List.  The
ensuing dialog lets you
pick from among all the currently installed fonts in your system, their sizes,
and any of the standard typefaces.  For a given font, the items in the Text
Size popup menu that are displayed in outline are the best sizes for that
font.

Note: The Set Text Style… command is also at the service of
individual resource editors that support different text styles.

Once you’ve chosen a text style, click on OK to set it as the current style for
the frontmost File Window only.  This style will remain in effect until you
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close the window, or until you change it again.  If you also want to set the
default text style, click in the Save & OK button, which, after setting the
frontmost File Window’s current text style, installs the style in Resorcerer’s
preferences as the default, so that all subsequently opened File Windows
will have their current styles set to it.

The amount of space each resource in the Resources List takes up is
dependent on the size of the current text style.  Initially, when Resorcerer is
shipped, the default text style is set to Geneva 9 Bold, but if you work on a
large screen, you may want to set it to a larger font size.

PRINTING A RESOURCE
LISTING

To get a listing of any or all of the resources in a
given file, make sure the File Window is the
frontmost, and choose either Print To Printer…
or Print To Text File… from the File menu.

Print To Printer… is the same as other
standard Print commands: the listing is sent
directly to the printer.  You must fill out the
fields in the Macintosh’s Standard Print Dialog
and click on its OK button to continue.

Print To Text File… creates a similar listing, only it writes it in plain
ASCII to a given text file.  Resorcerer asks you to specify the name of the file
first.  The text file is given whatever TEXT file signature you have set in the
Preferences… dialog (for more on this, see the “Preferences” chapter later
in the manual).

In either case, Resorcerer creates a dated listing of all resources of all
selected types if the Types List is the Active List, or all selected resources of
the given type,  if the Resources List is Active.

Note: If the Types List is the Active List and no resource types are
selected (as occurs just after opening the file), both Print
commands will assume you want a full listing of all types and
resources in the file.

Each entry in the listing gives the resource type, ID, name, attribute bits,
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and size in bytes.  The attribute bits are printed using the same icons as are
shown in the Resources List, with a legend printed at the head of the listing.
For text files, text abbreviations are used instead.

The listing you create with Print To Printer… will be subject to whatever
settings you specify when you use Page Setup… in the File menu.

Sorcery: c P is the keyboard equivalent of Print To Printer….
You can also choose Print from the File menu without actually
traversing the attached hierarchical menu.  This is the same as
choosing Print To Printer….


